Skip to content

← Public intelligence

Maven package

org.craftercms:crafter-core

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.5MavenPublished

    Missing Authorization in Crafter CMS

    CVE-2017-15680 · GHSA-2rr8-9c6g-8j5c

    Affected
    • Maven org.craftercms:crafter-core >= 3.0.0, < 3.0.1
    Fixed in
    3.0.1· Vendor fix available
    Issue
    In Crafter CMS Crafter Studio 3.0 prior to 3.0.1 an IDOR vulnerability exists which allows unauthenticated attackers to view and modify administrative data.

    Recommended action: Upgrade to 3.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 8.6MavenPublished

    XML injection in Crafter CMS

    CVE-2017-15683 · GHSA-p2vm-88rg-wfr2

    Affected
    • Maven org.craftercms:crafter-core >= 3.0.0, < 3.0.1
    Fixed in
    3.0.1· Vendor fix available
    Issue
    In Crafter CMS Crafter Studio 3.0 prior to 3.0.1 an unauthenticated attacker is able to create a site with specially crafted XML that allows the retrieval of OS files out-of-band.

    Recommended action: Upgrade to 3.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. UnratedMavenPublished

    Cross site scripting in Crafter CMS

    CVE-2017-15682 · GHSA-38rq-rh9w-cmw6

    Affected
    • Maven org.craftercms:crafter-core >= 3.0.0, < 3.0.1
    Fixed in
    3.0.1· Vendor fix available
    Issue
    In Crafter CMS Crafter Studio 3.0.1 an unauthenticated attacker is able to inject malicious JavaScript code resulting in a stored/blind XSS in the admin panel.

    Recommended action: Upgrade to 3.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →