Skip to content

← Public intelligence

Maven package

org.codehaus.groovy:groovy

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8MavenPublished

    Improper Neutralization of Special Elements in Output Used by a Downstream Component in Apache Groovy

    CVE-2015-3253 · GHSA-qg25-hgjv-cg9q

    Affected
    • Maven org.codehaus.groovy:groovy >= 1.7.0, <= 2.4.3
    Fixed in
    2.4.4· Vendor fix available
    Issue
    The MethodClosure class in runtime/MethodClosure.java in Apache Groovy 1.7.0 through 2.4.3 allows remote attackers to execute arbitrary code or cause a denial of service via a crafted serialized object.

    Recommended action: Upgrade to 2.4.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.8MavenPublished

    Deserialization of Untrusted Data in Groovy

    CVE-2016-6814 · GHSA-xphj-m9cc-8fmq

    Affected
    • Maven org.codehaus.groovy:groovy >= 1.7.0, <= 2.4.7
    Fixed in
    2.4.8· Vendor fix available
    Issue
    When an application with unsupported Codehaus versions of Groovy from 1.7.0 to 2.4.3, Apache Groovy 2.4.4 to 2.4.7 on classpath uses standard Java serialization mechanisms, e.g. to communicate between servers or to store local data, it was possible for an attacker to bake a special serialized object that will execute code directly when deserialized. All applications which rely on serialization and do not isolate the code which deserializes objects were subject to this vulnerability.

    Recommended action: Upgrade to 2.4.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 5.5MavenPublished

    Information Disclosure in Apache Groovy

    CVE-2020-17521 · GHSA-rcjj-h6gh-jf3r

    Affected
    • Maven org.codehaus.groovy:groovy >= 2.0.0, < 2.4.21; >= 2.5.0, < 2.5.14; >= 3.0.0, < 3.0.7
    Fixed in
    2.5.143.0.72.4.21· Vendor fix available
    Issue
    Apache Groovy provides extension methods to aid with creating temporary directories. Prior to this fix, Groovy's implementation of those extension methods was using a now superseded Java JDK method call that is potentially not secure on some operating systems in some contexts. Users not using the extension methods mentioned in the advisory are not affected, but may wish to read the advisory for further details. Versions Affected: 2.0 to 2.4.20, 2.5.0 to 2.5.13, 3.0.0 to 3.0.6, and 4.0.0-alpha-1. Fixed in versions 2.4.21, 2.5.14, 3.0.7, 4.0.0-alpha-2.

    Recommended action: Upgrade to 3.0.7, 2.5.14 or 2.4.21 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →