Medium, CVSS 5.3MavenPublished
Apache Zeppelin SAP: connecting to a malicious SAP server allowed it to perform XXE
CVE-2022-47894 · GHSA-rr59-h6rh-v84v
- Affected
- Maven org.apache.zeppelin:sap >= 0.8.0, < 0.11.0
- Fixed in
- 0.11.0· Vendor fix available
- Issue
- Improper Input Validation vulnerability in Apache Zeppelin SAP. This issue affects Apache Zeppelin SAP: from 0.8.0 before 0.11.0. As this project is retired, we do not plan to release a version that fixes this issue. Users are recommended to find an alternative or restrict access to the instance to trusted users. For more information, the fix already was merged in the source code but Zeppelin decided to retire the SAP component NOTE: This vulnerability only affects products that are no longer supported by the maintainer.
Recommended action: Upgrade to 0.11.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.