High, CVSS 7.1MavenPublished
Apache XML Graphics Batik Server-Side Request Forgery vulnerability
CVE-2022-44729 · GHSA-gq5f-xv48-2365
- Affected
- Maven org.apache.xmlgraphics:batik-transcoder >= 1.0, < 1.17
- Fixed in
- 1.17· Vendor fix available
- Issue
- Server-Side Request Forgery (SSRF) vulnerability in Apache Software Foundation Apache XML Graphics Batik.This issue affects Apache XML Graphics Batik: 1.16. On version 1.16, a malicious SVG could trigger loading external resources by default, causing resource consumption or in some cases even information disclosure. Users are recommended to upgrade to version 1.17 or later.
Recommended action: Upgrade to 1.17 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.