Critical, CVSS 9.1MavenPublished
Improper Restriction of Recursive Entity References in Apache XMLBeans
CVE-2021-23926 · GHSA-mw3r-pfmg-xp92
- Affected
- Maven org.apache.xmlbeans:xmlbeans < 3.0.0
- Fixed in
- 3.0.0· Vendor fix available
- Issue
- The XML parsers used by XMLBeans up to version 2.6.0 did not set the properties needed to protect the user from malicious XML input. Vulnerabilities include possibilities for XML Entity Expansion attacks. Affects XMLBeans up to and including v2.6.0.
Recommended action: Upgrade to 3.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.