Skip to content

← Public intelligence

Maven package

org.apache.ws.security:wss4j

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratedMavenPublished

    Improper Access Control in Apache WSS4J

    CVE-2015-0227 · GHSA-6r5v-hp32-fjqw

    Affected
    • Maven org.apache.ws.security:wss4j < 1.6.17; >= 2.0.0, < 2.02
    Fixed in
    1.6.172.02· Vendor fix available
    Issue
    Apache WSS4J before 1.6.17 and 2.x before 2.0.2 allows remote attackers to bypass the requireSignedEncryptedDataElements configuration via a vectors related to "wrapping attacks."

    Recommended action: Upgrade to 2.02 or 1.6.17 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.5MavenPublished

    Use of a Broken or Risky Cryptographic Algorithm in Apache WSS4J

    CVE-2015-0226 · GHSA-vjwc-5hfh-2vv5

    Affected
    • Maven org.apache.ws.security:wss4j < 1.6.17
    Fixed in
    1.6.17· Vendor fix available
    Issue
    Apache WSS4J before 1.6.17 and 2.0.x before 2.0.2 improperly leaks information about decryption failures when decrypting an encrypted key or message data, which makes it easier for remote attackers to recover the plaintext form of a symmetric key via a series of crafted messages. NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-2487.

    Recommended action: Upgrade to 1.6.17 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. UnratedMavenPublished

    Improper Authentication in Apache WSS4J

    CVE-2014-3623 · GHSA-99v3-9x35-c5vf

    Affected
    • Maven org.apache.ws.security:wss4j < 1.6.17
    Fixed in
    1.6.17· Vendor fix available
    Issue
    Apache WSS4J before 1.6.17 and 2.x before 2.0.2, as used in Apache CXF 2.7.x before 2.7.13 and 3.0.x before 3.0.2, when using TransportBinding, does not properly enforce the SAML SubjectConfirmation method security semantics, which allows remote attackers to conduct spoofing attacks via unspecified vectors.

    Recommended action: Upgrade to 1.6.17 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Medium, CVSS 5.9MavenPublished

    Use of a Broken or Risky Cryptographic Algorithm in Apache WSS4J

    CVE-2011-2487 · GHSA-4qqf-hmv6-r6wh

    Affected
    • Maven org.apache.ws.security:wss4j < 1.6.5
    Fixed in
    1.6.5· Vendor fix available
    Issue
    The implementations of PKCS#1 v1.5 key transport mechanism for XMLEncryption in JBossWS and Apache WSS4J before 1.6.5 is susceptible to a Bleichenbacher attack.

    Recommended action: Upgrade to 1.6.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →