Skip to content

← Public intelligence

Maven package

org.apache.wicket:wicket-util

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratedMavenPublished

    Apache Wicket: Remote code execution via XSLT injection

    CVE-2024-36522 · GHSA-hhwc-gh8h-9rrp

    Affected
    • Maven org.apache.wicket:wicket-util >= 10.0.0-M1, < 10.1.0; >= 9.0.0, < 9.18.0; >= 8.0.0, < 8.16.0
    Fixed in
    10.1.09.18.08.16.0· Vendor fix available
    Issue
    The default configuration of XSLTResourceStream.java is vulnerable to remote code execution via XSLT injection when processing input from an untrusted source without validation. Users are recommended to upgrade to versions 10.1.0, 9.18.0 or 8.16.0, which fix this issue.

    Recommended action: Upgrade to 10.1.0, 9.18.0 or 8.16.0 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →