Skip to content

← Public intelligence

Maven package

org.apache.unomi:unomi

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8MavenPublished

    Injection and Improper Input Validation in Apache Unomi

    CVE-2020-13942 · GHSA-xp5j-wj4h-2jq9

    Affected
    • Maven org.apache.unomi:unomi < 1.5.2
    Fixed in
    1.5.2· Vendor fix available
    Issue
    It is possible to inject malicious OGNL or MVEL scripts into the /context.json public endpoint. This was partially fixed in 1.5.1 but a new attack vector was found. In Apache Unomi version 1.5.2 scripts are now completely filtered from the input. It is highly recommended to upgrade to the latest available version of the 1.5.x release to fix this problem.

    Recommended action: Upgrade to 1.5.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.8MavenPublished

    Improper Input Validation in Apache Unomi

    CVE-2020-11975 · GHSA-v6fq-q792-j46j

    Affected
    • Maven org.apache.unomi:unomi < 1.5.4
    Fixed in
    1.5.4· Vendor fix available
    Issue
    Apache Unomi allows conditions to use OGNL scripting which offers the possibility to call static Java classes from the JDK that could execute code with the permission level of the running Java process.

    Recommended action: Upgrade to 1.5.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 7.5MavenPublished

    Command injection in Apache Unomi

    CVE-2021-31164 · GHSA-rm7f-mpcj-w4f6

    Affected
    • Maven org.apache.unomi:unomi < 1.5.5
    Fixed in
    1.5.5· Vendor fix available
    Issue
    Apache Unomi prior to version 1.5.5 allows CRLF log injection because of the lack of escaping in the log statements.

    Recommended action: Upgrade to 1.5.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →