Critical, CVSS 9.1MavenPublished
Apache Tomcat has an Always-Incorrect Control Flow Implementation vulnerability
CVE-2026-55276 · GHSA-mqg3-r7h5-24x4
- Affected
- Maven org.apache.tomcat:tomcat-util-scan >= 11.0.0-M1, < 11.0.23; >= 10.1.0-M1, < 10.1.56; >= 9.0.0.M1, < 9.0.119; >= 8.5.0, <= 8.5.100
- Fixed in
- 10.1.569.0.11911.0.23· Partial vendor fix
- Issue
- Always-Incorrect Control Flow Implementation vulnerability in Apache Tomcat meant that special roles and empty authorisation constraints were not included when the effective web.xml was logged. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.0.M1 through 9.0.118, from 8.5.0 through 8.5.100. Other versions that have reached end of support may also be affected. Users are recommended to upgrade to version 11.0.23, 10.1.56 or 9.0.119 which fixes the issue.
Recommended action: Upgrade to 11.0.23, 10.1.56 or 9.0.119 by release line; some affected versions have no fix yet, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.