Critical, CVSS 9.8Exploited · CISA KEVMavenPublished
Apache Tomcat Improper Access Control vulnerability
CVE-2016-8735 · GHSA-cw54-59pw-4g8c
- Affected
- Maven org.apache.tomcat:tomcat-catalina-jmx-remote < 6.0.48; >= 7.0.0, < 7.0.73; >= 8.0.0, < 8.0.39; >= 8.5.0, < 8.5.7; >= 9.0.0.M1, < 9.0.0.M12
- Fixed in
- 7.0.739.0.0.M126.0.488.5.78.0.39· Vendor fix available
- Issue
- Remote code execution is possible with Apache Tomcat before 6.0.48, 7.x before 7.0.73, 8.x before 8.0.39, 8.5.x before 8.5.7, and 9.x before 9.0.0.M12 if JmxRemoteLifecycleListener is used and an attacker can reach JMX ports. The issue exists because this listener wasn't updated for consistency with the CVE-2016-3427 Oracle patch that affected credential types.
Recommended action: Upgrade to 9.0.0.M12, 8.5.7, 8.0.39 or 2 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.