Medium, CVSS 5.3MavenPublished
Apache Tomcat Vulnerable to Cross-Site Scripting
CVE-2007-1355 · GHSA-4c6x-gfc8-c26r
- Affected
- Maven org.apache.tomcat:jsp-api >= 4.1.0, < 4.1.37; >= 5.5.0, < 5.5.24; >= 6.0.0, < 6.0.11; >= 5.0.0, <= 5.0.30; >= 4.0.0, <= 4.0.6
- Fixed in
- 6.0.115.5.244.1.37· Partial vendor fix
- Issue
- Multiple cross-site scripting (XSS) vulnerabilities in the appdev/sample/web/hello.jsp example application in Tomcat 4.0.0 through 4.0.6, 4.1.0 through 4.1.36, 5.0.0 through 5.0.30, 5.5.0 through 5.5.23, and 6.0.0 through 6.0.10 allow remote attackers to inject arbitrary web script or HTML via the test parameter and unspecified vectors.
Recommended action: Upgrade to 6.0.11, 5.5.24 or 4.1.37 by release line; some affected versions have no fix yet, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.