Critical, CVSS 9.8MavenPublished
Serialization vulnerability in Apache Tapestry
CVE-2020-17531 · GHSA-c566-2grg-mjwg
- Affected
- Maven org.apache.tapestry:tapestry-project >= 4.0, < 5.0.1
- Fixed in
- 5.0.1· Vendor fix available
- Issue
- A Java Serialization vulnerability was found in Apache Tapestry 4. Apache Tapestry 4 will attempt to deserialize the "sp" parameter even before invoking the page's validate method, leading to deserialization without authentication. Apache Tapestry 4 reached end of life in 2008 and no update to address this issue will be released. Apache Tapestry 5 versions are not vulnerable to this issue. Users of Apache Tapestry 4 should upgrade to the latest Apache Tapestry 5 version.
Recommended action: Upgrade to 5.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.