Skip to content

← Public intelligence

Maven package

org.apache.syncope.core:syncope-core-provisioning-api

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.9MavenPublished

    Apache Syncope Vulnerable to Exposure of Sensitive Information Through Data Queries

    CVE-2026-42797 · GHSA-vr35-jm2f-8wg2

    Affected
    • Maven org.apache.syncope.core:syncope-core-provisioning-api >= 3.0.0-M0, <= 3.0.16; >= 4.0.0-M0, < 4.0.6; >= 4.1.0-M0, < 4.1.1
    Fixed in
    4.0.64.1.1· Partial vendor fix
    Issue
    Exposure of Sensitive Information Through Data Queries vulnerability in Apache Syncope. An administrator with adequate entitlements for Derived Schemas can create a malicious JEXL expression which allows any administrator with sufficient entitlements for User read to access User-related security-sensitive information. This issue affects Apache Syncope: 3.0 through 3.0.16, 4.0 through 4.0.5, 4.1.0. Users are recommended to upgrade to version 4.0.6 / 4.1.1, which fix this issue by further restricting the JEXL expression definition.

    Recommended action: Upgrade to 4.1.1 or 4.0.6 by release line; some affected versions have no fix yet, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →