Skip to content

← Public intelligence

Maven package

org.apache.syncope.client:syncope-client-enduser

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.4MavenPublished

    Cross-site scripting in Apache Syncome EndUser

    CVE-2019-17557 · GHSA-6qj8-c27w-rp33

    Affected
    • Maven org.apache.syncope.client:syncope-client-enduser < 2.0.15; >= 2.1.0, < 2.1.6
    Fixed in
    2.0.152.1.6· Vendor fix available
    Issue
    It was found that the Apache Syncope EndUser UI login page prio to 2.0.15 and 2.1.6 reflects the successMessage parameters. By this mean, a user accessing the Enduser UI could execute javascript code from URL query string.

    Recommended action: Upgrade to 2.1.6 or 2.0.15 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →