Skip to content

← Public intelligence

Maven package

org.apache.syncope:syncope

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratedMavenPublished

    Apache Syncope uses a weak PNRG

    CVE-2014-3503 · GHSA-4c72-mrhf-23cg

    Affected
    • Maven org.apache.syncope:syncope >= 1.1.0, < 1.1.8
    Fixed in
    1.1.8· Vendor fix available
    Issue
    Apache Syncope 1.1.x before 1.1.8 uses weak random values to generate passwords, which makes it easier for remote attackers to guess the password via a brute force attack.

    Recommended action: Upgrade to 1.1.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. UnratedMavenPublished

    Apache Syncope JEXL Code Injection

    CVE-2014-0111 · GHSA-r2xf-w5pj-9pw8

    Affected
    • Maven org.apache.syncope:syncope >= 1.0.0, < 1.0.9; >= 1.1.0, < 1.1.7
    Fixed in
    1.0.91.1.7· Vendor fix available
    Issue
    Apache Syncope 1.0.0 before 1.0.9 and 1.1.0 before 1.1.7 allows remote administrators to execute arbitrary Java code via vectors related to Apache Commons JEXL expressions, "derived schema definition," "user / role templates," and "account links of resource mappings."

    Recommended action: Upgrade to 1.1.7 or 1.0.9 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 7.2MavenPublished

    Shell command injection in Apache Syncope

    CVE-2020-11977 · GHSA-p2rp-cmjq-r7wm

    Affected
    • Maven org.apache.syncope:syncope >= 2.1.0, < 2.1.7
    Fixed in
    2.1.7· Vendor fix available
    Issue
    In Apache Syncope 2.1.X releases prior to 2.1.7, when the Flowable extension is enabled, an administrator with workflow entitlements can use Shell Service Tasks to perform malicious operations, including but not limited to file read, file write, and code execution.

    Recommended action: Upgrade to 2.1.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →