Skip to content

← Public intelligence

Maven package

org.apache.struts:struts2-parent

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratedMavenPublished

    Apache Struts Multiple XSS Vulnerabilities

    CVE-2011-2087 · GHSA-5pgj-r7c6-7c7w

    Affected
    • Maven org.apache.struts:struts2-parent < 2.2.3
    Fixed in
    2.2.3· Vendor fix available
    Issue
    Multiple cross-site scripting (XSS) vulnerabilities in component handlers in the javatemplates (aka Java Templates) plugin in Apache Struts 2.x before 2.2.3 allow remote attackers to inject arbitrary web script or HTML via an arbitrary parameter value to a .action URI, related to improper handling of value attributes in 1. FileHandler.java 1. HiddenHandler.java 1. PasswordHandler.java 1. RadioHandler.java 1. ResetHandler.java 1. SelectHandler.java 1. SubmitHandler.java 1. TextFieldHandler.java

    Recommended action: Upgrade to 2.2.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. UnratedMavenPublished

    Apache Struts Multiple Cross-site Scripting Vulnerabilities

    CVE-2012-1006 · GHSA-cmpm-jg8r-fv37

    Affected
    • Maven org.apache.struts:struts2-parent <= 2.0.14; >= 2.2, <= 2.2.3
    Fixed in
    2.2.3.12.1.2· Vendor fix available
    Issue
    Multiple cross-site scripting (XSS) vulnerabilities in Apache Struts 2.0.14 and 2.2.3 allow remote attackers to inject arbitrary web script or HTML via the (1) name or (2) lastName parameter to struts2-showcase/person/editPerson.action, or the (3) clientName parameter to struts2-rest-showcase/orders.

    Recommended action: Upgrade to 2.2.3.1 or 2.1.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 8.8MavenPublished

    Apache Struts RCE Vulnerability

    CVE-2016-3090 · GHSA-ggmp-fxfg-277r

    Affected
    • Maven org.apache.struts:struts2-parent >= 2.0.0, < 2.3.20
    Fixed in
    2.3.20· Vendor fix available
    Issue
    The TextParseUtil.translateVariables method in Apache Struts 2.x before 2.3.20 allows remote attackers to execute arbitrary code via a crafted OGNL expression with ANTLR tooling.

    Recommended action: Upgrade to 2.3.20 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →