UnratedMavenPublished
Apache Struts Dojo Plugin XSS Vulnerability
CVE-2007-6726 · GHSA-rm26-w253-9qv7
- Affected
- Maven org.apache.struts:struts2-dojo-plugin >= 0.4.1, <= 0.4.2
- Fixed in
- 0.4.3· Vendor fix available
- Issue
- Multiple cross-site scripting (XSS) vulnerabilities in Dojo 0.4.1 and 0.4.2, as used in Apache Struts and other products, allow remote attackers to inject arbitrary web script or HTML via unspecified vectors involving (1) xipclient.html and (2) xipserver.html in src/io/.
Recommended action: Upgrade to 0.4.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.