Critical, CVSS 9.8MavenPublished
Path Traversal in Apache Struts
CVE-2016-6795 · GHSA-44hv-jjx7-qfjg
- Affected
- Maven org.apache.struts:struts2-convention-plugin >= 2.3.0, < 2.3.31; >= 2.5.0, < 2.5.5
- Fixed in
- 2.5.52.3.31· Vendor fix available
- Issue
- In Apache Struts 2.3.x before 2.3.31, and 2.5.x before 2.5.5, it is possible to prepare a special URL which will be used for path traversal and execution of arbitrary code on server side. This vulnerability is only exploitable when using the Struts 2 Convention plugin in conjunction with Apache Struts.
Recommended action: Upgrade to 2.5.5 or 2.3.31 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.