Skip to content

← Public intelligence

Maven package

org.apache.storm:storm

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8MavenPublished

    Apache Storm remote code execution vulnerability

    CVE-2015-3188 · GHSA-cg5h-q983-4rww

    Affected
    • Maven org.apache.storm:storm >= 0.10.0-beta, <= 0.10.0-beta
    Fixed in
    0.10.0-beta1· Vendor fix available
    Issue
    The UI daemon in Apache Storm 0.10.0-beta allows remote users to run arbitrary code as the user running the web server. With kerberos authentication this could allow impersonation of arbitrary users on other systems, including HDFS and HBase.

    Recommended action: Upgrade to 0.10.0-beta1 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.8MavenPublished

    Deserialization of Untrusted Data leading to Remote Code Execution in Apache Storm

    CVE-2021-40865 · GHSA-w729-7633-2fw5

    Affected
    • Maven org.apache.storm:storm >= 2.2.0, < 2.2.1; >= 1.0.0, < 1.2.4; >= 2.1.0, < 2.1.1
    Fixed in
    1.2.42.1.12.2.1· Vendor fix available
    Issue
    An Unsafe Deserialization vulnerability exists in the worker services of the Apache Storm supervisor server allowing pre-auth Remote Code Execution (RCE). Apache Storm 2.2.x users should upgrade to version 2.2.1 or 2.3.0. Apache Storm 2.1.x users should upgrade to version 2.1.1. Apache Storm 1.x users should upgrade to version 1.2.4

    Recommended action: Upgrade to 2.2.1, 2.1.1 or 1.2.4 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Critical, CVSS 9.8MavenPublished

    Command injection leading to Remote Code Execution in Apache Storm

    CVE-2021-38294 · GHSA-6768-mcjc-8223

    Affected
    • Maven org.apache.storm:storm >= 2.2.0, < 2.2.1; >= 2.0.0, < 2.1.1; >= 1.0.0, < 1.2.4
    Fixed in
    1.2.42.1.12.2.1· Vendor fix available
    Issue
    A Command Injection vulnerability exists in the getTopologyHistory service of the Apache Storm 2.x prior to 2.2.1 and Apache Storm 1.x prior to 1.2.4. A specially crafted thrift request to the Nimbus server allows Remote Code Execution (RCE) prior to authentication.

    Recommended action: Upgrade to 2.2.1, 2.1.1 or 1.2.4 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →