Skip to content

← Public intelligence

Maven package

org.apache.solr:solr-solrj

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.9MavenPublished

    Apache Solr's Streaming Expressions allow users to extract data from other Solr Clouds

    CVE-2023-50298 · GHSA-xrj7-x7gp-wwqr

    Affected
    • Maven org.apache.solr:solr-solrj >= 9.0.0, < 9.4.1; >= 6.0.0, < 8.11.3
    Fixed in
    8.11.39.4.1· Vendor fix available
    Issue
    Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Solr. This issue affects Apache Solr from 6.0.0 through 8.11.2, from 9.0.0 before 9.4.1. Solr Streaming Expressions allows users to extract data from other Solr Clouds, using a "zkHost" parameter. When original SolrCloud is setup to use ZooKeeper credentials and ACLs, they will be sent to whatever "zkHost" the user provides. An attacker could setup a server to mock ZooKeeper, that accepts ZooKeeper requests with credentials and ACLs and extracts the sensitive information, then send a streaming expression using the mock server's address in "zkHost". Streaming Expressions are exposed via the "/streaming" handler, with "read" permissions. Users are recommended to upgrade to version 8.11.3 or 9.4.1, which fix the issue. From these versions on, only zkHost values that have the same server address (regardless of chroot), will use the given ZooKeeper credentials and ACLs when connecting.

    Recommended action: Upgrade to 9.4.1 or 8.11.3 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.8MavenPublished

    Incorrect Authorization in Apache Solr

    CVE-2020-13957 · GHSA-3c7p-vv5r-cmr5

    Affected
    • Maven org.apache.solr:solr-solrj >= 6.6.0, < 8.6.3
    Fixed in
    8.6.3· Vendor fix available
    Issue
    Apache Solr versions 6.6.0 to 6.6.6, 7.0.0 to 7.7.3 and 8.0.0 to 8.6.2 prevents some features considered dangerous (which could be used for remote code execution) to be configured in a ConfigSet that's uploaded via API without authentication/authorization. The checks in place to prevent such features can be circumvented by using a combination of UPLOAD/CREATE actions. This issue is patched in 8.6.3.

    Recommended action: Upgrade to 8.6.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →