High, CVSS 7.5MavenPublished
Command injection in Apache Sling
CVE-2023-25141 · GHSA-gvg3-83q4-rfhq
- Affected
- Maven org.apache.sling:org.apache.sling.jcr.base < 3.1.12
- Fixed in
- 3.1.12· Vendor fix available
- Issue
- Apache Sling JCR Base < 3.1.12 has a critical injection vulnerability when running on old JDK versions (JDK 1.8.191 or earlier) through utility functions in RepositoryAccessor. The functions getRepository and getRepositoryFromURL allow an application to access data stored in a remote location via JDNI and RMI. Users of Apache Sling JCR Base are recommended to upgrade to Apache Sling JCR Base 3.1.12 or later, or to run on a more recent JDK.
Recommended action: Upgrade to 3.1.12 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.