Skip to content

← Public intelligence

Maven package

org.apache.shenyu:shenyu-common

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

6 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.5MavenPublished

    Apache Shenyu Server Side Request Forgery vulnerability

    CVE-2023-25753 · GHSA-7w8v-5fcq-pvqw

    Affected
    • Maven org.apache.shenyu:shenyu-common < 2.6.0
    Fixed in
    2.6.0· Vendor fix available
    Issue
    There exists an SSRF (Server-Side Request Forgery) vulnerability located at the /sandbox/proxyGateway endpoint. This vulnerability allows us to manipulate arbitrary requests and retrieve corresponding responses by inputting any URL into the requestUrl parameter. Of particular concern is our ability to exert control over the HTTP method, cookies, IP address, and headers. This effectively grants us the capability to dispatch complete HTTP requests to hosts of our choosing. This issue affects Apache ShenYu: 2.5.1. Upgrade to Apache ShenYu 2.6.0 or apply patch https://github.com/apache/shenyu/pull/4776 .

    Recommended action: Upgrade to 2.6.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 8.8MavenPublished

    Apache ShenYu Admin has insecure permissions

    CVE-2022-37435 · GHSA-fjjw-82xw-vfc2

    Affected
    • Maven org.apache.shenyu:shenyu-common >= 2.4.2, <= 2.4.3
    Fixed in
    2.5.0· Vendor fix available
    Issue
    Apache ShenYu Admin has insecure permissions, which may allow low-privilege administrators to modify high-privilege administrator's passwords. This issue affects Apache ShenYu 2.4.2 and 2.4.3. Version 2.5.0 contains a patch for this issue.

    Recommended action: Upgrade to 2.5.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 7.5MavenPublished

    Missing authentication in ShenYu

    CVE-2022-23945 · GHSA-7rjp-fgwj-47rw

    Affected
    • Maven org.apache.shenyu:shenyu-common >= 2.4.0, < 2.4.2
    Fixed in
    2.4.2· Vendor fix available
    Issue
    Missing authentication on ShenYu Admin when register by HTTP. This issue affected Apache ShenYu 2.4.0 and 2.4.1.

    Recommended action: Upgrade to 2.4.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. High, CVSS 7.5MavenPublished

    Password exposure in ShenYu

    CVE-2022-23223 · GHSA-7wq4-89xx-g62j

    Affected
    • Maven org.apache.shenyu:shenyu-common >= 2.4.0, < 2.4.2
    Fixed in
    2.4.2· Vendor fix available
    Issue
    On Apache ShenYu versions 2.4.0 and 2.4.1, and endpoint existed that disclosed the passwords of all users. Users are recommended to upgrade to version 2.4.2 or later.

    Recommended action: Upgrade to 2.4.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. Critical, CVSS 9.1MavenPublished

    Missing authentication in ShenYu

    CVE-2022-23944 · GHSA-6v39-p2xq-g5c3

    Affected
    • Maven org.apache.shenyu:shenyu-common >= 2.4.0, < 2.4.2
    Fixed in
    2.4.2· Vendor fix available
    Issue
    User can access /plugin api without authentication. This issue affected Apache ShenYu 2.4.0 and 2.4.1.

    Recommended action: Upgrade to 2.4.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. Critical, CVSS 9.8MavenPublished

    Code injection in ShenYu

    CVE-2021-45029 · GHSA-gh38-x2wm-xmc8

    Affected
    • Maven org.apache.shenyu:shenyu-common >= 2.4.0, < 2.4.2
    Fixed in
    2.4.2· Vendor fix available
    Issue
    Groovy Code Injection & SpEL Injection which lead to Remote Code Execution. This issue affected Apache ShenYu 2.4.0 and 2.4.1.

    Recommended action: Upgrade to 2.4.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →