High, CVSS 8.1MavenPublished
Apache Seata: Deserialization of untrusted Data in Apache Seata Server
CVE-2025-53606 · GHSA-g358-g2pq-c46j
- Affected
- Maven org.apache.seata:seata-serializer-fury >= 2.4.0, <= 2.4.0
- Fixed in
- 2.5.0· Vendor fix available
- Issue
- Deserialization of Untrusted Data vulnerability in Apache Seata (incubating). This issue affects Apache Seata (incubating): 2.4.0. Users are recommended to upgrade to version 2.5.0, which fixes the issue.
Recommended action: Upgrade to 2.5.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.