Low, CVSS 2.7MavenPublished
Apache Seata Vulnerable to Data Amplification
CVE-2024-54016 · GHSA-65vg-64g8-mwjr
- Affected
- Maven org.apache.seata:seata-parent >= 2.0.0, < 2.3.0
- Fixed in
- 2.3.0· Vendor fix available
- Issue
- Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Seata (incubating). This issue affects Apache Seata (incubating): through <=2.2.0. Users are recommended to upgrade to version 2.3.0, which fixes the issue.
Recommended action: Upgrade to 2.3.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.