Critical, CVSS 9.2MavenPublished
Apache Seata Deserialization of Untrusted Data vulnerability
CVE-2024-22399 · GHSA-3xq2-w6j4-c99r
- Affected
- Maven org.apache.seata:seata-core >= 1.0.0, < 1.8.1; >= 2.0.0, <= 2.0.0
- Fixed in
- 1.8.12.1.0· Vendor fix available
- Issue
- Deserialization of Untrusted Data vulnerability in Apache Seata. When developers disable authentication on the Seata-Server and do not use the Seata client SDK dependencies, they may construct uncontrolled serialized malicious requests by directly sending bytecode based on the Seata private protocol. This issue affects Apache Seata: 2.0.0, from 1.0.0 through 1.8.0. Users are recommended to upgrade to version 2.1.0/1.8.1, which fixes the issue.
Recommended action: Upgrade to 2.1.0 or 1.8.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.