UnratedMavenPublished
Apache Rave information disclosure vulnerability
CVE-2013-1814 · GHSA-428j-q447-47rw
- Affected
- Maven org.apache.rave:rave-core >= 0.11, < 0.20.1
- Fixed in
- 0.20.1· Vendor fix available
- Issue
- The users/get program in the User RPC API in Apache Rave 0.11 through 0.20 allows remote authenticated users to obtain sensitive information about all user accounts via the offset parameter, as demonstrated by discovering password hashes in the password field of a response.
Recommended action: Upgrade to 0.20.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.