Skip to content

← Public intelligence

Maven package

org.apache.ranger:ranger-plugins-common

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8MavenPublished

    Apache Ranger has a Code Injection vulnerability

    CVE-2025-59059 · GHSA-c87w-642h-m97h

    Affected
    • Maven org.apache.ranger:ranger-plugins-common < 2.8.0
    Fixed in
    2.8.0· Vendor fix available
    Issue
    Remote Code Execution Vulnerability in NashornScriptEngineCreator is reported in Apache Ranger versions <= 2.7.0. Users are recommended to upgrade to version 2.8.0, which fixes this issue.

    Recommended action: Upgrade to 2.8.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 5.9MavenPublished

    Apache Ranger policy engine incorrectly matches paths in certain conditions

    CVE-2016-8746 · GHSA-xv7x-x6wr-xx7g

    Affected
    • Maven org.apache.ranger:ranger-plugins-common < 0.6.3
    Fixed in
    0.6.3· Vendor fix available
    Issue
    Apache Ranger before 0.6.3 policy engine incorrectly matches paths in certain conditions when policy does not contain wildcards and has recursion flag set to true.

    Recommended action: Upgrade to 0.6.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →