Medium, CVSS 5.3MavenPublished
Apache Ranger Vulnerable to Improper Validation of Certificate with Host Mismatch
CVE-2025-59060 · GHSA-5fvg-qwcp-r325
- Affected
- Maven org.apache.ranger:ranger-nifi-registry-plugin < 2.8.0
- Fixed in
- 2.8.0· Vendor fix available
- Issue
- Hostname verification bypass issue in Apache Ranger NiFiRegistryClient/NiFiClient is reported in Apache Ranger versions <= 2.7.0. Users are recommended to upgrade to version 2.8.0, which fixes this issue.
Recommended action: Upgrade to 2.8.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.