High, CVSS 8.1MavenPublished
Apache Ranger Hive Plugin missing permissions check
CVE-2021-40331 · GHSA-vjr2-wpfh-5r9p
- Affected
- Maven org.apache.ranger:ranger-hive-plugin >= 2.0.0, < 2.4.0
- Fixed in
- 2.4.0· Vendor fix available
- Issue
- An Incorrect Permission Assignment for Critical Resource vulnerability was found in the Apache Ranger Hive Plugin. Any user with SELECT privilege on a database can alter the ownership of the table in Hive when Apache Ranger Hive Plugin is enabled This issue affects Apache Ranger Hive Plugin: from 2.0.0 through 2.3.0. Users are recommended to upgrade to version 2.4.0 or later.
Recommended action: Upgrade to 2.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.