High, CVSS 7.5MavenPublished
Improper Input Validation in Apache Qpid AMQP 0-x JMS
CVE-2016-4974 · GHSA-f38p-mq64-h784
- Affected
- Maven org.apache.qpid:qpid-jms-client <= 0.9.0
- Fixed in
- 0.10.0· Vendor fix available
- Issue
- Apache Qpid AMQP 0-x JMS client before 6.0.4 and JMS (AMQP 1.0) before 0.10.0 does not restrict the use of classes available on the classpath, which might allow remote authenticated users with permission to send messages to deserialize arbitrary objects and execute arbitrary code by leveraging a crafted serialized object in a JMS ObjectMessage that is handled by the getObject function.
Recommended action: Upgrade to 0.10.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.