Medium, CVSS 5.9MavenPublished
Apache Pulsar Java Client vulnerable to Improper Certificate Validation
CVE-2022-33681 · GHSA-c5fp-x2h5-vjv7
- Affected
- Maven org.apache.pulsar:pulsar-client < 2.7.5; >= 2.8.0, < 2.8.4; >= 2.9.0, < 2.9.3; >= 2.10.0, <= 2.10.0
- Fixed in
- 2.10.12.9.32.7.52.8.4· Vendor fix available
- Issue
- Delayed TLS hostname verification in the Pulsar Java Client and the Pulsar Proxy make each client vulnerable to a man in the middle attack. Connections from the Pulsar Java Client to the Pulsar Broker/Proxy and connections from the Pulsar Proxy to the Pulsar Broker are vulnerable. Authentication data is sent before verifying the server’s TLS certificate matches the hostname, which means authentication data could be exposed to an attacker. An attacker can only take advantage of this vulnerability by taking control of a machine 'between' the client and the server. The attacker must then actively manipulate traffic to perform the attack by providing the client with a cryptographically valid certificate for an unrelated host. Because the client sends authentication data before performing hostname verification, an attacker could gain access to the client’s authentication data. The client eventually closes the connection when it verifies the hostname and identifies the targeted hostname…
Recommended action: Upgrade to 2.10.1, 2.9.3, 2.8.4 or 2.7.5 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.