Skip to content

← Public intelligence

Maven package

org.apache.portals.pluto:pluto-portal

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1MavenPublished

    Cross-site Scripting in Apache Pluto

    CVE-2021-36739 · GHSA-3qp6-m7hp-jrwf

    Affected
    • Maven org.apache.portals.pluto:pluto-portal < 3.1.1
    Fixed in
    3.1.1· Vendor fix available
    Issue
    The "first name" and "last name" fields of the Apache Pluto 3.1.0 MVCBean JSP portlet maven archetype are vulnerable to Cross-Site Scripting (XSS) attacks.

    Recommended action: Upgrade to 3.1.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. UnratedMavenPublished

    Cross-site Scripting in Apache Pluto

    CVE-2021-36737 · GHSA-x588-g38j-f672

    Affected
    • Maven org.apache.portals.pluto:pluto-portal < 3.1.1
    Fixed in
    3.1.1· Vendor fix available
    Issue
    The input fields of the Apache Pluto UrlTestPortlet are vulnerable to Cross-Site Scripting (XSS) attacks. Users should migrate to version 3.1.1 of the v3-demo-portlet.war artifact

    Recommended action: Upgrade to 3.1.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. UnratedMavenPublished

    Cross-site Scripting in Apache Pluto

    CVE-2021-36738 · GHSA-jg6j-jrxv-2hh9

    Affected
    • Maven org.apache.portals.pluto:pluto-portal < 3.1.1
    Fixed in
    3.1.1· Vendor fix available
    Issue
    The input fields in the JSP version of the Apache Pluto Applicant MVCBean CDI portlet are vulnerable to Cross-Site Scripting (XSS) attacks. Users should migrate to version 3.1.1 of the applicant-mvcbean-cdi-jsp-portlet.war artifact

    Recommended action: Upgrade to 3.1.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →