Skip to content

← Public intelligence

Maven package

org.apache.portals.pluto:chatRoomDemo

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1MavenPublished

    Cross-site Scripting in Apache Pluto Chatroom demo

    CVE-2019-0186 · GHSA-w47g-4vrc-m3w2

    Affected
    • Maven org.apache.portals.pluto:chatRoomDemo >= 3.0.0, < 3.1.0
    Fixed in
    3.1.0· Vendor fix available
    Issue
    The input fields of the Apache Pluto "Chat Room" demo portlet 3.0.0 and 3.0.1 are vulnerable to Cross-Site Scripting (XSS) attacks. Mitigation: Uninstall the ChatRoomDemo war file - or - migrate to version 3.1.0 of the chat-room-demo war file

    Recommended action: Upgrade to 3.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →