Skip to content

← Public intelligence

Maven package

org.apache.portals.jetspeed-2:jetspeed

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.2MavenPublished

    Path Traversal in Apache Jetspeed

    CVE-2016-0709 · GHSA-w47p-5q88-hj5g

    Affected
    • Maven org.apache.portals.jetspeed-2:jetspeed < 2.3.1
    Fixed in
    2.3.1· Vendor fix available
    Issue
    Directory traversal vulnerability in the Import/Export function in the Portal Site Manager in Apache Jetspeed before 2.3.1 allows remote authenticated administrators to write to arbitrary files, and consequently execute arbitrary code, via a .. (dot dot) in a ZIP archive entry, as demonstrated by "../../webapps/x.jsp."

    Recommended action: Upgrade to 2.3.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 8.8MavenPublished

    Apache Jetspeed vulnerable to SQL Injection

    CVE-2016-0710 · GHSA-88f6-79x2-xqf3

    Affected
    • Maven org.apache.portals.jetspeed-2:jetspeed < 2.3.1
    Fixed in
    2.3.1· Vendor fix available
    Issue
    Multiple SQL injection vulnerabilities in the User Manager service in Apache Jetspeed before 2.3.1 allow remote attackers to execute arbitrary SQL commands via the (1) role or (2) user parameter to services/usermanager/users/.

    Recommended action: Upgrade to 2.3.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 6.1MavenPublished

    Cross-site Scripting in Apache Jetspeed

    CVE-2016-0712 · GHSA-hj2v-85ph-8g48

    Affected
    • Maven org.apache.portals.jetspeed-2:jetspeed < 2.3.1
    Fixed in
    2.3.1· Vendor fix available
    Issue
    Cross-site scripting (XSS) vulnerability in Apache Jetspeed before 2.3.1 allows remote attackers to inject arbitrary web script or HTML via the PATHINFO to portal.

    Recommended action: Upgrade to 2.3.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →