Skip to content

← Public intelligence

Maven package

org.apache.parquet:parquet-avro

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.1MavenPublished

    Apache Parquet Java: Potential malicious code execution from trusted packages in the parquet-avro module when reading an Avro schema from a Parquet file metadata

    CVE-2025-46762 · GHSA-53wx-pr6q-m3j5

    Affected
    • Maven org.apache.parquet:parquet-avro < 1.15.2
    Fixed in
    1.15.2· Vendor fix available
    Issue
    Schema parsing in the parquet-avro module of Apache Parquet 1.15.0 and previous versions allows bad actors to execute arbitrary code. While 1.15.1 introduced a fix to restrict untrusted packages, the default setting of trusted packages still allows malicious classes from these packages to be executed. The exploit is only applicable if the client code of parquet-avro uses the "specific" or the "reflect" models deliberately for reading Parquet files. ("generic" model is not impacted) Users are recommended to upgrade to 1.15.2 or set the system property "org.apache.parquet.avro.SERIALIZABLEPACKAGES" to an empty string on 1.15.1. Both are sufficient to fix the issue.

    Recommended action: Upgrade to 1.15.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 10.0MavenPublished

    Apache Parquet Avro Module Vulnerable to Arbitrary Code Execution

    CVE-2025-30065 · GHSA-2c59-37c4-qrx5

    Affected
    • Maven org.apache.parquet:parquet-avro < 1.15.1
    Fixed in
    1.15.1· Vendor fix available
    Issue
    Schema parsing in the parquet-avro module of Apache Parquet 1.15.0 and previous versions allows bad actors to execute arbitrary code Users are recommended to upgrade to version 1.15.1, which fixes the issue.

    Recommended action: Upgrade to 1.15.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →