High, CVSS 7.5MavenPublished
Improper Input Validation in Parquet-MR
CVE-2021-41561 · GHSA-gc67-crq6-hgh5
- Affected
- Maven org.apache.parquet:parquet >= 1.12.0, < 1.12.2; < 1.11.2
- Fixed in
- 1.12.21.11.2· Vendor fix available
- Issue
- Improper Input Validation vulnerability in Parquet-MR of Apache Parquet allows an attacker to DoS by malicious Parquet files. This issue affects Apache Parquet-MR version 1.9.0 and later versions.
Recommended action: Upgrade to 1.12.2 or 1.11.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.