Skip to content

← Public intelligence

Maven package

org.apache.oozie:oozie-core

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.5MavenPublished

    Path Traversal in Apache Oozie

    CVE-2017-15712 · GHSA-2fx6-r6qx-3c7h

    Affected
    • Maven org.apache.oozie:oozie-core >= 3.1.3, < 5.0.0
    Fixed in
    5.0.0· Vendor fix available
    Issue
    Vulnerability allows a user of Apache Oozie 3.1.3-incubating to 4.3.0 and 5.0.0-beta1 to expose private files on the Oozie server process. The malicious user can construct a workflow XML file containing XML directives and configuration that reference sensitive files on the Oozie server host.

    Recommended action: Upgrade to 5.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.5MavenPublished

    Moderate severity vulnerability that affects org.apache.oozie:oozie-core

    CVE-2018-11799 · GHSA-wg5w-vv93-3f7w

    Affected
    • Maven org.apache.oozie:oozie-core <= 5.0.0
    Fixed in
    5.1.0· Vendor fix available
    Issue
    Vulnerability allows a user of Apache Oozie 3.1.3-incubating to 5.0.0 to impersonate other users. The malicious user can construct an XML that results workflows running in other user's name.

    Recommended action: Upgrade to 5.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →