High, CVSS 7.9MavenPublished
Improper Neutralization of Input in Advanced User Interface for Jolt
CVE-2023-49145 · GHSA-68pr-6fjc-wmgm
- Affected
- Maven org.apache.nifi:nifi-jolt-transform-json-ui < 1.24.0
- Fixed in
- 1.24.0· Vendor fix available
- Issue
- Apache NiFi 0.7.0 through 1.23.2 include the JoltTransformJSON Processor, which provides an advanced configuration user interface that is vulnerable to DOM-based cross-site scripting. If an authenticated user, who is authorized to configure a JoltTransformJSON Processor, visits a crafted URL, then arbitrary JavaScript code can be executed within the session context of the authenticated user. Upgrading to Apache NiFi 1.24.0 or 2.0.0-M1 is the recommended mitigation.
Recommended action: Upgrade to 1.24.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.