Skip to content

← Public intelligence

Maven package

org.apache.nifi:nifi-dbcp-service

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.7MavenPublished

    Apache NiFi Code Injection vulnerability

    CVE-2023-36542 · GHSA-r969-8v3h-23v9

    Affected
    • Maven org.apache.nifi:nifi-dbcp-service >= 0.0.2, < 1.23.0
    Fixed in
    1.23.0· Vendor fix available
    Issue
    Apache NiFi 0.0.2 through 1.22.0 include Processors and Controller Services that support HTTP URL references for retrieving drivers, which allows an authenticated and authorized user to configure a location that enables custom code execution. The resolution introduces a new Required Permission for referencing remote resources, restricting configuration of these components to privileged users. The permission prevents unprivileged users from configuring Processors and Controller Services annotated with the new Reference Remote Resources restriction. Upgrading to Apache NiFi 1.23.0 is the recommended mitigation.

    Recommended action: Upgrade to 1.23.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →