Critical, CVSS 9.8MavenPublished
Apache MyFaces Trinidad Deserialization Vulnerability
CVE-2016-5019 · GHSA-x7rc-4gqw-3q6q
- Affected
- Maven org.apache.myfaces.trinidad:trinidad >= 1.0.0, <= 1.0.13; >= 1.2.0, < 1.2.15; >= 2.0.0, < 2.0.2; >= 2.1.0, < 2.1.2
- Fixed in
- 2.1.22.0.21.2.15· Partial vendor fix
- Issue
- CoreResponseStateManager in Apache MyFaces Trinidad 1.0.0 through 1.0.13, 1.2.x before 1.2.15, 2.0.x before 2.0.2, and 2.1.x before 2.1.2 might allow attackers to conduct deserialization attacks via a crafted serialized viewstate string.
Recommended action: Upgrade to 2.1.2, 2.0.2 or 1.2.15 by release line; some affected versions have no fix yet, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.