Medium, CVSS 5.1MavenPublished
Deserialization of Untrusted Data vulnerability in Apache Lucene Replicator.
CVE-2024-45772 · GHSA-g643-xq6w-r67c
- Affected
- Maven org.apache.lucene:lucene-replicator >= 4.4.0, < 9.12.0
- Fixed in
- 9.12.0· Vendor fix available
- Issue
- This issue affects Apache Lucene's replicator module: from 4.4.0 before 9.12.0. The deprecated org.apache.lucene.replicator.http package is affected. The org.apache.lucene.replicator.nrt package is not affected. Users are recommended to upgrade to version 9.12.0, which fixes the issue. The deserialization can only be triggered if users actively deploy an network-accessible implementation and a corresponding client using a HTTP library that uses the API (e.g., a custom servlet and HTTPClient). Java serialization filters (such as -Djdk.serialFilter='!' on the commandline) can mitigate the issue on vulnerable versions without impacting functionality.
Recommended action: Upgrade to 9.12.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.