Critical, CVSS 9.8MavenPublished
Apache Linkis JDBC EngineConn has deserialization vulnerability
CVE-2023-29215 · GHSA-qm2h-m799-86rc
- Affected
- Maven org.apache.linkis:linkis-engineconn < 1.3.2
- Fixed in
- 1.3.2· Vendor fix available
- Issue
- In Apache Linkis <=1.3.1, due to the lack of effective filtering of parameters, an attacker configuring malicious Mysql JDBC parameters in JDBC EngineConn Module will trigger a deserialization vulnerability and eventually lead to remote code execution. Therefore, the parameters in the Mysql JDBC URL should be blacklisted. Users should upgrade their version of Linkis to version 1.3.2.
Recommended action: Upgrade to 1.3.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.