Skip to content

← Public intelligence

Maven package

org.apache.linkis:linkis-datasource

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.7MavenPublished

    Apache Linkis DataSource's JDBC Datasource Module with DB2 has JNDI Injection vulnerability

    CVE-2023-49566 · GHSA-7qpc-4xx9-x5qw

    Affected
    • Maven org.apache.linkis:linkis-datasource < 1.6.0
    Fixed in
    1.6.0· Vendor fix available
    Issue
    In Apache Linkis <=1.5.0, due to the lack of effective filteringof parameters, an attacker configuring malicious db2 parameters in the DataSource Manager Module will result in jndi injection. Therefore, the parameters in the DB2 URL should be blacklisted. This attack requires the attacker to obtain an authorized account from Linkis before it can be carried out. Versions of Apache Linkis <=1.5.0 will be affected. We recommend users upgrade the version of Linkis to version 1.6.0.

    Recommended action: Upgrade to 1.6.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.7MavenPublished

    Apache Linkis DataSource remote code execution vulnerability

    CVE-2023-46801 · GHSA-jjvc-v8gw-5255

    Affected
    • Maven org.apache.linkis:linkis-datasource >= 1.4.0, < 1.6.0
    Fixed in
    1.6.0· Vendor fix available
    Issue
    In Apache Linkis <= 1.5.0, data source management module, when adding Mysql data source, exists remote code execution vulnerability for java version < 1.8.0241. The deserialization vulnerability exploited through jrmp can inject malicious files into the server and execute them. This attack requires the attacker to obtain an authorized account from Linkis before it can be carried out. We recommend that users upgrade the java version to = 1.8.0241. Or users upgrade Linkis to version 1.6.0.

    Recommended action: Upgrade to 1.6.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 7.1MavenPublished

    Apache Linkis DataSource allows arbitrary file reading

    CVE-2023-41916 · GHSA-f22j-9j59-33j4

    Affected
    • Maven org.apache.linkis:linkis-datasource >= 1.4.0, < 1.6.0
    Fixed in
    1.6.0· Vendor fix available
    Issue
    In Apache Linkis = 1.4.0, due to the lack of effective filtering of parameters, an attacker configuring malicious Mysql JDBC parameters in the DataSource Manager Module will trigger arbitrary file reading. Therefore, the parameters in the Mysql JDBC URL should be blacklisted. This attack requires the attacker to obtain an authorized account from Linkis before it can be carried out. Versions of Apache Linkis = 1.4.0 will be affected. We recommend users upgrade the version of Linkis to version 1.6.0.

    Recommended action: Upgrade to 1.6.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Critical, CVSS 9.8MavenPublished

    Apache Linkis DatasourceManager module has deserialization vulnerability

    CVE-2023-29216 · GHSA-rrhf-32rq-f28h

    Affected
    • Maven org.apache.linkis:linkis-datasource < 1.3.2
    Fixed in
    1.3.2· Vendor fix available
    Issue
    In Apache Linkis <=1.3.1, because the parameters are not effectively filtered, the attacker can use the MySQL data source and malicious parameters to configure a new data source to trigger a deserialization vulnerability, eventually leading to remote code execution. Users should upgrade their version of Linkis to version 1.3.2.

    Recommended action: Upgrade to 1.3.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →