High, CVSS 8.8MavenPublished
Apache Kyuubi Server vulnerable to Path Traversal
CVE-2025-66518 · GHSA-f8r6-6222-9pvc
- Affected
- Maven org.apache.kyuubi:kyuubi-server_2.12 >= 1.6.0, < 1.10.3
- Fixed in
- 1.10.3· Vendor fix available
- Issue
- Any client who can access to Apache Kyuubi Server via Kyuubi frontend protocols can bypass server-side config kyuubi.session.local.dir.allow.list and use local files which are not listed in the config. This issue affects Apache Kyuubi: from 1.6.0 through 1.10.2. Users are recommended to upgrade to version 1.10.3 or upper, which fixes the issue.
Recommended action: Upgrade to 1.10.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.