Critical, CVSS 9.8MavenPublished
Apache Kylin vulnerable to remote code execution
CVE-2022-24697 · GHSA-ppxx-m926-g569
- Affected
- Maven org.apache.kylin:kylin-spark-project < 4.0.2
- Fixed in
- 4.0.2· Vendor fix available
- Issue
- Kylin's cube designer function has a command injection vulnerability when overwriting system parameters in the configuration overwrites menu. RCE can be implemented by closing the single quotation marks around the parameter value of “-- conf=” to inject any operating system command into the command line parameters. This vulnerability affects Kylin 2 version 2.6.5 and earlier, Kylin 3 version 3.1.2 and earlier, and Kylin 4 version 4.0.1 and earlier.
Recommended action: Upgrade to 4.0.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.