Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.
Open advisories
11 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.
A carefully crafted request on several JSPWiki plugins could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.12.0 or later.
Recommended action: Upgrade to 2.12.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
In Apache JSPWiki, up to version 2.11.0.M4, a carefully crafted plugin link invocation could trigger an XSS vulnerability on Apache JSPWiki, related to the remember parameter on some of the JSPs, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim.
Recommended action: Upgrade to 2.11.0.M5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
On Apache JSPWiki, up to version 2.11.0.M4, a carefully crafted plugin link invocation could trigger an XSS vulnerability on Apache JSPWiki, related to InfoContent.jsp, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim.
Recommended action: Upgrade to 2.11.0.M5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
On Apache JSPWiki, up to version 2.11.0.M4, a carefully crafted plugin link invocation could trigger an XSS vulnerability on Apache JSPWiki, related to the WYSIWYG editor, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim.
Recommended action: Upgrade to 2.11.0.M5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
On Apache JSPWiki, up to version 2.11.0.M4, a carefully crafted plugin link invocation could trigger an XSS vulnerability on Apache JSPWiki, related to the Page Revision History, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim.
Recommended action: Upgrade to 2.11.0.M5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
On Apache JSPWiki, up to version 2.11.0.M4, a carefully crafted plugin link invocation could trigger an XSS vulnerability on Apache JSPWiki, related to the plain editor, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim.
Recommended action: Upgrade to 2.11.0.M5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
A carefully crafted plugin link invocation could trigger an XSS vulnerability on Apache JSPWiki 2.9.0 to 2.11.0.M3, which could lead to session hijacking. Initial reporting indicated ReferredPagesPlugin, but further analysis showed that multiple plugins were vulnerable.
Recommended action: Upgrade to 2.11.0.M4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
A carefully crafted InterWiki link could trigger an XSS vulnerability on Apache JSPWiki 2.9.0 to 2.11.0.M3, which could lead to session hijacking.
Recommended action: Upgrade to 2.11.0.M4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
A carefully crafted malicious attachment could trigger an XSS vulnerability on Apache JSPWiki 2.9.0 to 2.11.0.M3, which could lead to session hijacking.
Recommended action: Upgrade to 2.11.0.M4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
A specially crafted url could be used to access files under the ROOT directory of the application on Apache JSPWiki 2.9.0 to 2.11.0.M2, which could be used by an attacker to obtain registered users' details.
Recommended action: Upgrade to 2.11.0.M3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
A carefully crafted URL could trigger an XSS vulnerability on Apache JSPWiki, from versions up to 2.10.5, which could lead to session hijacking.
Recommended action: Upgrade to 2.11.0.M1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.