Skip to content

← Public intelligence

Maven package

org.apache.jena:jena-fuseki

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.9MavenPublished

    Apache Jena allows users with administrator access to create databases files outside the files area of the Fuseki server

    CVE-2025-49656 · GHSA-jq2c-m8gg-mqcm

    Affected
    • Maven org.apache.jena:jena-fuseki < 5.5.0
    Fixed in
    5.5.0· Vendor fix available
    Issue
    Users with administrator access can create databases files outside the files area of the Fuseki server. This issue affects Apache Jena version up to 5.4.0. Users are recommended to upgrade to version 5.5.0, which fixes the issue.

    Recommended action: Upgrade to 5.5.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.1MavenPublished

    Cross-site scripting in Apache Jena Fuseki

    CVE-2021-33192 · GHSA-phwj-86vx-cfjc

    Affected
    • Maven org.apache.jena:jena-fuseki >= 2.0.0, <= 4.0.0
    Fixed in
    4.1.0· Vendor fix available
    Issue
    A vulnerability in the HTML pages of Apache Jena Fuseki allows an attacker to execute arbitrary javascript on certain page views. This issue affects Apache Jena Fuseki from version 2.0.0 to version 4.0.0 (inclusive).

    Recommended action: Upgrade to 4.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →