Skip to content

← Public intelligence

Maven package

org.apache.jena:jena

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.2MavenPublished

    Apache Jena doesn't validate file access paths in configuration files uploaded by users with administrator access

    CVE-2025-50151 · GHSA-xg9p-p463-3qjp

    Affected
    • Maven org.apache.jena:jena < 5.5.0
    Fixed in
    5.5.0· Vendor fix available
    Issue
    File access paths in configuration files uploaded by users with administrator access are not validated. This issue affects Apache Jena version up to 5.4.0. Users are recommended to upgrade to version 5.5.0, which does not allow arbitrary configuration upload.

    Recommended action: Upgrade to 5.5.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 8.8MavenPublished

    Apache Jena Expression Language Injection vulnerability

    CVE-2023-32200 · GHSA-j927-w6g7-7c7w

    Affected
    • Maven org.apache.jena:jena >= 3.7.0, < 4.9.0
    Fixed in
    4.9.0· Vendor fix available
    Issue
    There is insufficient restrictions of called script functions in Apache Jena versions 4.8.0 and earlier. It allows a remote user to execute javascript via a SPARQL query. This issue affects Apache Jena from 3.7.0 through 4.8.0.

    Recommended action: Upgrade to 4.9.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 5.4MavenPublished

    Arbitrary javascript injection in Apache Jena

    CVE-2023-22665 · GHSA-xgh5-gwq5-rpx8

    Affected
    • Maven org.apache.jena:jena < 4.8.0
    Fixed in
    4.8.0· Vendor fix available
    Issue
    There is insufficient checking of user queries in Apache Jena versions 4.7.0 and earlier, when invoking custom scripts. It allows a remote user to execute arbitrary javascript via a SPARQL query.

    Recommended action: Upgrade to 4.8.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Critical, CVSS 9.8MavenPublished

    XML External Entity Reference in apache jena

    CVE-2022-28890 · GHSA-gchv-364h-r896

    Affected
    • Maven org.apache.jena:jena >= 4.4.0, <= 4.4.0
    Fixed in
    4.5.0· Vendor fix available
    Issue
    A vulnerability in the RDF/XML parser of Apache Jena allows an attacker to cause an external DTD to be retrieved. This issue affects Apache Jena version 4.4.0 only. Apache Jena 4.2.x and 4.3.x do not allow external entities.

    Recommended action: Upgrade to 4.5.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →