High, CVSS 8.6MavenPublished
Apache James vulnerable to denial of service through the use of IMAP literals
CVE-2024-37358 · GHSA-56jp-w6vw-j3jw
- Affected
- Maven org.apache.james.protocols:protocols-imap < 3.7.6; >= 3.8.0, < 3.8.2
- Fixed in
- 3.7.63.8.2· Vendor fix available
- Issue
- Similarly to CVE-2024-34055, Apache James is vulnerable to denial of service through the abuse of IMAP literals from both authenticated and unauthenticated users, which could be used to cause unbounded memory allocation and very long computations Version 3.7.6 and 3.8.2 restrict such illegitimate use of IMAP literals.
Recommended action: Upgrade to 3.8.2 or 3.7.6 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.