High, CVSS 7.8MavenPublished
Apache James server's JMX management service vulnerable to privilege escalation by local user
CVE-2023-26269 · GHSA-w7r6-v4j7-h94w
- Affected
- Maven org.apache.james:javax-mail-extension < 3.7.4
- Fixed in
- 3.7.4· Vendor fix available
- Issue
- Apache James server version 3.7.3 and earlier provides a JMX management service without authentication by default. This allows privilege escalation by a malicious local user. Administrators are advised to disable JMX, or set up a JMX password. Note that version 3.7.4 onward will set up a JMX password automatically for Guice users.
Recommended action: Upgrade to 3.7.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.